advertisement
from the Engineering department...
Modbus comms between Micrologix 1100 and Multilin 735 relay
Communications systems and equipment. topic
Posted by Shawn Norton on 18 February, 2008 - 7:29 pm
I cannot get my modbus comms to work between an AB Micrologix 1100 and a GE Multilin hooked up DH485.

I have done alot of modbus with the SLC and the Contrologix units but this is the 1st with an 1100 and I cannot get it to talk.

Any ideas or sample "msg" commands


Posted by Trevor Ousey on 19 February, 2008 - 10:34 pm
Hi Shawn,

Send me an email and I can send a copy of a ML1100 using Modbus with a burner controller. It wasn't as hard as I expected, just the array in the PLC was out by 1 compared to the Modbus addressing.

Cheers,
Trevor
Tousey.list [at] bigpond [dot] com


Posted by Victor Garcia on 3 May, 2008 - 4:54 pm
it would be great when you send me some info, about modbus over micrologix processor, i also have some projects about it.


Posted by Steven on 19 February, 2008 - 10:36 pm
Would recommend to use a Serial Analyzer to trouble-shoot the problems, maybe you can try to use the analyzer software and port powered converters from this site: http://www.CommFront.com.

Steven


Posted by Ken Roach on 19 February, 2008 - 10:39 pm
DH485 is a specific A-B protocol that runs over RS-485 wiring. Don't mistake it for other protocols (Modbus, DF1 Half Duplex, ASCII) that also can be run over RS-485 wiring.

Do you have any information about error codes, or how you wired up the connection, or what Modbus function codes and addresses you are trying to read or write?

One important thing I've found with the MicroLogix 1100 when you are using Modbus with the built-in RS485 port and 1763-NC01 cable is that you need to set the Handshaking mode to "No Handshaking (485 Network)" which is the last on the list of handshaking options.


Posted by Shawn Norton on 21 February, 2008 - 1:17 am
Thanks for the reply. As per the 735 relay I should be able to talk Modbus RTU via the 2-wire RS485 hardware and the 735 can only be a slave device. According to the MicroLogix, it can be set up as master or slave modbus RTU via the RS-485 hardware using the 1763-NC01. I have tried multiple combinations of handshaking, etc. In the message command I have also tried several combinations of:
read holding registers
read input registers
data table address = N7:0
size in elements = 1 (until I can get it talking)
target device mb data address =1 (which should correspond to addresss 0000 or 0001 in the modbus memory map - again not sure until I get it talking but I should get values to populate the n7:0 register either way
slave node address =1 (as per my dip switch settings on the 735)

I've had no luck... Thanks again for the help reply with any suggestions! If you can give me an email address I can send you screen shots if appropriate.


Posted by Carl Burgess on 21 February, 2008 - 12:41 am
I've just used a MicroLogix 1100 with Modbus last week. Works a treat.

A few pointers:

There's a simple getting started guide in the AB knowledgebase that helped me. It's called 'Quickstart Modbus Channel Configuration for MicroLogix 1100/1200/1500'

The serial port (Ch0) has to be set up for Modbus, not DF1 - this means programming through the ethernet port. I just used a crossover patch lead, and ran the BOOTP server that comes with RSLinx.

I think you will need a SVC instruction somewhere in your ladder to service the comms.

Hopes this helps.


Posted by chapssa on 21 February, 2008 - 12:46 am
The Multilin 735 baud rate setting and unit (slave) is set with the switch located in front of the relay.

1. Configure the 735 relay's baud rate and slave address to 19200 and 1 (or any one you desire).
2. Launch the Enervista 735 setup program. (http://www.enervista.com)
3. Configure the setup program baud rate and slave address.
4. US RS232 cable to connect your PC with DH485 and to the relay.
5. Establish communication (instruction is located in the instruction book or can be downloaded from http://www.multilin.com or http://www.enervista.com).
6. If you still have a problem, try to get the GE Multilin F485 protocol converter to communicate with the relay.
7. Attempt to isolate the problem to setting, relay, protocol converter, or AB Micrologix 1100.

Good luck.


Posted by Carl Ellis on 22 February, 2008 - 12:25 am
>7. Attempt to isolate the problem to
>setting, relay, protocol converter, or
>AB Micrologix 1100. <

Good advice.

Consider using a PC with one of the freeware or shareware Modbus Master programs (Simply Modbus, Win-Tech's Modscan32, or ModPoll) and a 232/485 converter for the serial port, to establish the conditions under which slave unit operates.

Then go to the Micrologix.

Carl

Your use of this site is subject to the terms and conditions set forth under Legal Notices and the Privacy Policy. Please read those terms and conditions carefully. Subject to the rights expressly reserved to others under Legal Notices, the content of this site and the compilation thereof is © 1999-2014 Nerds in Control, LLC. All rights reserved.

Users of this site are benefiting from open source technologies, including PHP, MySQL and Apache. Be happy. This page served by Yesod4.


Fortune
index, n.:
Alphabetical list of words of no possible interest where an
alphabetical list of subjects with references ought to be.
Advertise here
Advertisement
our advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive